Русский New site

Advanced search

[ New messages · Forum rules · Members ]
Page 1 of 212»
Forum » SpaceEngine » Troubleshooting and Solutions » Low quality planets in version 0.94
Low quality planets in version 0.94
WifoutTeefDate: Tuesday, 05.07.2011, 08:08 | Message # 1
Observer
Group: Users
United States
Messages: 11
Status: Offline
Hello I just got Space Engine and I'm loving it so far, but I'm having a problem.

Whenever I zoom in on a planet, it is very low quality, even with LOD on 3 (ive tried all of the settings)

Moons often are low quality spheres and the asteroids are the same.

Terra planets which are supposed to have beautiful mountain ranges have no elevation and are flat and blurry.

My specs are very high and should be able to run this game:

AMD Phenom II x6 1035t Processor
AMD (ATI) HD5850 Graphics Card
8gb DDR3 RAM
1 TB 7200RPM Hard Drive


Edited by WifoutTeef - Tuesday, 05.07.2011, 08:10
 
SpaceEngineerDate: Tuesday, 05.07.2011, 11:34 | Message # 2
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4796
Status: Offline
How I can understand your problem if you do not attach the log file? Please show me the "se.log."

*





 
miros_0571Date: Tuesday, 05.07.2011, 15:08 | Message # 3
Astronaut
Group: Banned
Ukraine
Messages: 54
Status: Offline
Quote
WifoutTeef
Whenever I zoom in on a planet, it is very low quality, even with LOD on 3 (ive tried all of the settings)

Please do not use LOD +3. Use LOD -3 and will no more lags and crashes.





MS Windows 7 Ultimate 32-bit SP1
Intel Pentium 4 CPU 3.20GHz, 2,0GB RAM, NVIDIA GeForce GTX 260
 
WifoutTeefDate: Tuesday, 05.07.2011, 19:03 | Message # 4
Observer
Group: Users
United States
Messages: 11
Status: Offline
Here is se.log, SpaceEngineer

And, miros 0571, I am not having lags or crashes. My game just has very bad graphics and it shouldn't because I am using the highest LOD settings and I have very good hardware.

Attachments: 1021202.log(306Kb)
 
SpaceEngineerDate: Tuesday, 05.07.2011, 20:39 | Message # 5
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4796
Status: Offline
WifoutTeef,

Lag says that you have a problem with memory manager. It tries to release video memory even if it is empty, immediately after starting. This bug was in old versions, but in new version it must work. Try to disable procedural stars and procedural planets and restart the program. Go to Earth and check if it looks normal (detailed). Then go to some procedural planet on catalog stars. If it looks detailed there too, then enable procedural stars. So, check what system causes to incorrect workin of memory manager: textures on real planets, textures on procedural planets or procedural stars generator.
Next, try to disable memory auto detection or limit the memory usage: http://en.spaceengine.org/forum/4-58-1 (follow paragraphs 5-c and 5-e).





 
WifoutTeefDate: Tuesday, 05.07.2011, 21:32 | Message # 6
Observer
Group: Users
United States
Messages: 11
Status: Offline
Thanks for the response. Sadly none of those worked sad

My planets are still very low quality, even on maximum LOD

All my terra planets look like this on the surface: http://i.imgur.com/anRJX.jpg

They should look like this: http://meta.filesmelt.com/downloader.php?file=Sex_AS_FUUUUUCK.png

I have an ATI card. Does it have anything to do with this line of text?

BugMipmaps true // mipmap generation bug on ATI (crash)

Whenever I turn it to false, my game crashes.
 
SpaceEngineerDate: Tuesday, 05.07.2011, 22:13 | Message # 7
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4796
Status: Offline
Crash? This is strange. Anyway, issue is with the memory manager, not the LOD or bugfix settings. Try to download SE again and update your video drivers.

*





 
Deltawing777Date: Tuesday, 05.07.2011, 23:54 | Message # 8
Observer
Group: Users
United States
Messages: 11
Status: Offline
I too have same issues as wifouteef.
nvidia gts 250 1gig ram
e8500 dual core 3.16 ghz
Pics are here https://skydrive.live.com/?cid=b8....4%21175

Attachments: 3481124.log(42Kb)


Edited by Deltawing777 - Tuesday, 05.07.2011, 23:59
 
WifoutTeefDate: Wednesday, 06.07.2011, 00:17 | Message # 9
Observer
Group: Users
United States
Messages: 11
Status: Offline
Quote (Deltawing777)
I too have same issues as wifouteef.
nvidia gts 250 1gig ram
e8500 dual core 3.16 ghz
Pics are here https://skydrive.live.com/?cid=b8....4%21175


Does it do the same thing on procedural terra planets?

Also, SpaceEngineer, still nothing has worked. I'm going to try running SpaceEngine on my other computer. Any other suggestions in the mean time?

EDIT:

I tried it on another computer. Same problems.

The other computer has:

Intel Q6600 Processor
ATI 5750 Graphics Card
3gb DDR2 RAM

EDIT 2:

My friend has tried it as well. Same problems. His computer has:

AMD Phenom II x4 Processor
AMD (ATI) 6850 Graphics Card
4gb DDR2 RAM


Edited by WifoutTeef - Wednesday, 06.07.2011, 01:22
 
SpaceEngineerDate: Wednesday, 06.07.2011, 11:06 | Message # 10
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4796
Status: Offline
Quote (Deltawing777)
I too have same issues as wifouteef.

You do not have issues. You post screenshot from Earth, and its blurry snd less detail - that is because Earth is not a procedural planet. Earth's textures is stored on disk in SE folder, and have only 100-200 Mb. To reach such high level of details as on procedural planets, Earth texture pack must be several terabytes in size.

Quote (WifoutTeef)
I tried it on another computer. Same problems.

Quote (WifoutTeef)
My friend has tried it as well. Same problems.

Did you run the same copy of SE? Try to download it again from site, may be your copy is broken.

UPD: Try to run older version, is that issue still here?





 
WifoutTeefDate: Wednesday, 06.07.2011, 18:40 | Message # 11
Observer
Group: Users
United States
Messages: 11
Status: Offline
Just making sure, my planets are not supposed to look like this, correct? http://i.imgur.com/GowPw.jpg

My main problem is that I just simply cannot find any mountains and I feel like they should be there. I have tried downloading it several times and I've tried downloading .93. My game looks perfect until I go to a planet's surface and it's just very low quality.

Are you sure it's not a problem with AMD (ATI) graphics cards? I'm not the expert, but I feel like the problem has to do with the mipmapping bugfix for ATI cards.

EDIT: I found a planet with mountains. But they are still low quality and are nothing like pictures I see online.

I read online on here: http://forums.somethingawful.com/showthr....umber=5

A user (sunday punch) said that he has an ATI card and a lot of the planets are very flat like mine.

EDIT 2: I think I found the problem. The mipmapping has to be disabled for my card or else my game crashes whenever I go to a planet. This makes my game load in planet textures a lot slower and in often lower quality which explains my complaint.

I have found mountains on a few planets, but I've noticed they only appear if I press G to go to the planet and slowly scan the surface after it has rendered for mountains. Then I slowly go towards them and let them render. If I don't, the planet goes very low quality and has no mountains because my computer has not rendered them.

Is there a way to enable mipmapping on AMD (ATI) graphics cards?

(I may be 100% wrong, feel free to correct me)


Edited by WifoutTeef - Wednesday, 06.07.2011, 21:29
 
NeonDate: Wednesday, 06.07.2011, 21:32 | Message # 12
Explorer
Group: SE team
Australia
Messages: 205
Status: Offline
I have high end machine, and there's just no way you
can run it on LOD +3, it takes ages to see any views
on mountains. I wouldn't bother with it, as there's very
little difference I've seen between the high n low setting.
I find the low setting perfectly fine, and alot more beautiful.
 
SpaceEngineerDate: Thursday, 07.07.2011, 02:21 | Message # 13
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4796
Status: Offline
WifoutTeef, I don't understand how mipmap generation causes overflow of memory manager. Can you do this: set LOD to -3 (minus 3), then set LoaderBenchmark true in the end of the main.cfg, restart SE, fly over planet surface and send me a log again?
Enable mipmapping on ATI is impossible, if you got crash. I must make my own function to generate mipmaps instead of standard glGenerateMinmapEXT(), because it crashes sometimes on ATI. I don't know why. I hope I make it in next release.





 
WifoutTeefDate: Thursday, 07.07.2011, 06:06 | Message # 14
Observer
Group: Users
United States
Messages: 11
Status: Offline
Here is my se.log after benchmark. My game lags a lot whenever I set LoaderBenchmark true. So the results may be wrong.

Overall I think my problem has been fixed. After re-downloading the game and changing options that you told me to, it is showing higher quality planets. They're still lower quality than pictures I've seen online, but they're still very good to me.

Unless you have any more ideas, thank you for your help. Space Engine is a very cool game and I am very impressed by your work. Keep up the good work! smile

Attachments: 0512376.log(175Kb)
 
SpaceEngineerDate: Thursday, 07.07.2011, 14:50 | Message # 15
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4796
Status: Offline
Now log shows that planetary engine works normally. Lags is caused by recording a text strings in the log file after every loading/generating event. So turn off benchmark back.




 
Forum » SpaceEngine » Troubleshooting and Solutions » Low quality planets in version 0.94
Page 1 of 212»
Search: