Русский New site

Advanced search

[ New messages · Forum rules · Members ]
Page 1 of 11
Forum » SpaceEngine » Troubleshooting and Solutions » OpenGL out of memory crash in SE
OpenGL out of memory crash in SE
DigitalStormDate: Monday, 02.04.2012, 07:00 | Message # 1
Observer
Group: Newbies
Australia
Messages: 8
Status: Offline
Been playing around with SE for many hours now and I continue to get this OpenGL crash if I do lots of exploring crazy artifacts start to appear red text shows up in the middle of the screen saying that OpenGL has run out of memory then SE crashes. I have turned off fast loading 3d water and done all that yet it continues to happen I also read the SE.log file to make sure it was using all of my Vram which it isn't I have 4095Mb of texture memory available on my graphics cards yet SE is only using 1420Mb and the file does say "Dynamic video memory detection enabled" I have included the SE.log file with the post to help understand what is going on. If it is only detecting 1420Mb of texture memory that means its not detecting the other 3 GPU's right? Wouldn't that mean there is lots of hardware power there to be used which SE isn't using for some reason...

I am running a Intel i7 6 core 2 Nvidia GTX 590's with 12Gb of RAM with Windows 7 64bit.
If anyone could help me to solve this really annoying crash it would be much appreciated thanks for the help everyone.

Attachments: 3097857.log(32Kb)
 
SpaceEngineerDate: Monday, 02.04.2012, 12:34 | Message # 2
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4796
Status: Offline
You have only 1.5 Gb of VRAM for each GPU. SLI does not allow use of 3 Gb, it works like RAID 1 - the second GPU's memory is just a mirror of the first one, but their computing power's distributed on the screen area.
Did you have the latest NVidia drivers? They seem to solve VRAM/RAM sharing issue, that allows SE to use additional RAM if out of VRAM size. See here: http://en.spaceengine.org/forum/11-515-1

*





 
DigitalStormDate: Tuesday, 03.04.2012, 01:47 | Message # 3
Observer
Group: Newbies
Australia
Messages: 8
Status: Offline
Yes im running the newest Nvidia drivers 296.10 also just tried manually changing video memory and turning off auto detect like they did in the other thread, it made no difference still crashed when I was just gliding on through the galaxy. I will upload my SE.log again maybe it will help. This is driving me crazy I love SE but it likes to crash on me. sad All I want to do is explore...
Attachments: 0348503.log(120Kb)
 
SpaceEngineerDate: Tuesday, 03.04.2012, 16:38 | Message # 4
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4796
Status: Offline
DigitalStorm, your video card/driver seems to still not work with shared memory. Re-enable memory auto detection. SE should work normally with 800 Mb of VRAM.

*





 
DigitalStormDate: Tuesday, 03.04.2012, 23:45 | Message # 5
Observer
Group: Newbies
Australia
Messages: 8
Status: Offline
I understand that it wont work with shared memory I was only trying what they said to do in the other thread. I have turned memory auto detection back on it still has the same crash, in fact I started again with a fresh copy of SE but still no change. I don't know what to do.... sad

Edit 1: Just tried using SE with every graphic option I could turned off or down to its lowest setting and it still crashed.


Edited by DigitalStorm - Wednesday, 04.04.2012, 11:06
 
SpaceEngineerDate: Wednesday, 04.04.2012, 11:39 | Message # 6
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4796
Status: Offline
DigitalStorm, wich VideoMemoryMaxPercent do you use (in main.cfg)?




 
DigitalStormDate: Wednesday, 04.04.2012, 14:59 | Message # 7
Observer
Group: Newbies
Australia
Messages: 8
Status: Offline
VideoMemoryMaxPercent is set to 85 however when it is crashing now no red text shows up saying GL out of memory it says run time has terminated in an usual way then I click on OK because its the only choice I have then it crashes.

Edit 1: Just tried with a completely fresh copy of SE with all the setting off or set to lowest and this time it gave me the GL out of memory error again. So any suggestions?


Edited by DigitalStorm - Sunday, 08.04.2012, 13:49
 
DigitalStormDate: Friday, 20.04.2012, 12:39 | Message # 8
Observer
Group: Newbies
Australia
Messages: 8
Status: Offline
Does anybody have a solution would really like to fix this problem? sad
 
DukeDate: Friday, 20.04.2012, 17:41 | Message # 9
Space Pilot
Group: SE team
Antarctica
Messages: 88
Status: Offline
What operation system do you have? If you use Windows 7 try to run SpaceEngine in Windows XP Compatible mode.
Try to use this settings in main.cfg

VideoMemorySize 1024 // video card onboard memory (VRAM) in megabytes
VideoMemoryMaxPercent 95 // max VRAM consumption (percents)
VideoMemoryStartupDetect false // use auto detection of VRAM size on startup, otherwise use VideoMemorySize value
VideoMemoryDynamicDetect false // use auto detection of available amount of VRAM in runtime

disable "Fast landscape loading" and set LOD to -1 in graphic settings.

One more thing, sometimes when you update old video drivers, it didn't correctly remove old files. It may be useful to try clear old drivers after uninstalling them from control panel with Driver Sweaper (http://www.guru3d.com/category/driversweeper/) and after that install new drivers.
 
DigitalStormDate: Saturday, 21.04.2012, 04:40 | Message # 10
Observer
Group: Newbies
Australia
Messages: 8
Status: Offline
Thank you Duke for your suggestion I think it might have helped a bit, however it still crashed no in game error message just a crash saying SE has stopped working, still thanks for helping out. Starting to look like I might just have to wait for a newer release of SE and hope that it fixes this problem.
 
Forum » SpaceEngine » Troubleshooting and Solutions » OpenGL out of memory crash in SE
Page 1 of 11
Search: