Русский New site

Advanced search

[ New messages · Forum rules · Members ]
Page 1 of 11
Forum » SpaceEngine » Troubleshooting and Solutions » Limiting Bloom
Limiting Bloom
NemoricusDate: Sunday, 29.03.2015, 16:36 | Message # 1
Observer
Group: Newbies
United States
Messages: 5
Status: Offline
Is there a way to limit the intensity of the bloom effect? I find that it gets overpowering in many instances, and there are times when it gets downright silly, like when I turned up the planet magnitude limit to twenty so that I could see faint objects and end up with planets that look larger than their parent star thanks to bloom.

Also, when it's most intense, it gets an artefactual square shape which I assume is due to a mask or texture used for the effect, and this is rather jarring to see.

So, is there a way to limit how intense the bloom effect gets? Or, failing that, a way to disable it entirely?
 
SolarLinerDate: Sunday, 29.03.2015, 18:12 | Message # 2
Explorer
Group: Users
France
Messages: 267
Status: Offline
Open the Graphics menu with CTRL+F4 and the top-left-most option is bloom intensity and activation.




custom landing page to share: http://bit.ly/spaceengine
 
NemoricusDate: Monday, 30.03.2015, 00:30 | Message # 3
Observer
Group: Newbies
United States
Messages: 5
Status: Offline
I just checked that, and I'm not seeing the option. I'm using 0.97.2, by the way.
 
BambusmanDate: Monday, 30.03.2015, 10:33 | Message # 4
Pioneer
Group: SE team
Germany
Messages: 408
Status: Offline
 
NemoricusDate: Monday, 30.03.2015, 18:18 | Message # 5
Observer
Group: Newbies
United States
Messages: 5
Status: Offline
Huh. I'm not sure how I missed the option, particularly since I have it set to 0.

So, my question is now: How do I limit bloom further than that option allows? Even at 0 it's too strong.
 
SolarLinerDate: Wednesday, 01.04.2015, 08:53 | Message # 6
Explorer
Group: Users
France
Messages: 267
Status: Offline
Well at 0 there's no bloom. I don't know what you are trying to do here. Maybe on the bottom right there's a "Planet Shine brighness" slider that you may want to turn down as well.




custom landing page to share: http://bit.ly/spaceengine
 
NemoricusDate: Wednesday, 01.04.2015, 19:45 | Message # 7
Observer
Group: Newbies
United States
Messages: 5
Status: Offline
It's not planet shine, because the effect applies to stars as well as planets. And if the effect isn't bloom, what do you call the effect that makes light sources look much larger than their actual size? Especially bright light sources?

I did notice that switching planets from 'point' to 'sprite' caused the squared-off artefact to go away, which is nice. But the effect is still present.
 
Billy_MayesDate: Wednesday, 01.04.2015, 21:25 | Message # 8
Pioneer
Group: Users
Finland
Messages: 485
Status: Offline
Try turning off diffraction spikes. If that's not it, try lowering star scale.




AMD Phenom II X4 955 3.2 GHz Quad-Core - AMD Radeon HD 6950 2GB VRAM - 4GB RAM - 1680x1050 75 Hz Samsung screen
 
SpaceEngineerDate: Wednesday, 01.04.2015, 21:54 | Message # 9
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4798
Status: Offline
I think you mean a halo around point sources, what looks like bloom. This is a particle rendering itself, it cannot be switched off.

You may modify shaders to remove it though. You must edit all shaders called star_sprite*.glsl and body_sprite*.glsl. In the beginnig of the shader, find this:

const float flarePower = 1.0;

Changing it to 4 removes flares completely. Making it less than 1 makes stars more "shiny", like on my dev screenshots.





 
Forum » SpaceEngine » Troubleshooting and Solutions » Limiting Bloom
Page 1 of 11
Search: