Русский New site

Advanced search

[ New messages · Forum rules · Members ]
Page 1 of 11
Forum » SpaceEngine » Troubleshooting and Solutions » Space Engine Uses All Virtual Memory, Causes Crrashes (Space Engine uses 100% of virtual memory and causes crashing)
Space Engine Uses All Virtual Memory, Causes Crrashes
lwaters1996Date: Sunday, 23.11.2014, 12:51 | Message # 1
Observer
Group: Newbies
Pirate
Messages: 5
Status: Offline
Space Engine uses 100% of my virtual memory and causes everything to crash.

Link to .CSV file showing virtual memory usage ramping up. .CSV files can be opened with any Office suite like LibreOffice or Microsoft Office.

Image of .CSV if you're lazy. Image also included as an attachment to the post.

So basically, after sitting in Space Engine for just a few minutes (I'd say I can't be in longer than 5 minutes these days), my virtual memory usgae goes up to max and then C++ has an unexpected death caused by Space Engine and it crashes everything. Chrome crashes, Skype crashes, explorer.exe crashes, everything. Sometimes I even have to reboot because it fucks up everything so hard.

I always kinda had this issue but I used to be able to play for a good several hours before something like this would happen.

I've tried things like reinstalling my Space Engine and what-not but to no avail. If anyone has any ideas (maybe something in some config file needs to be changed?) I'd love to hear them!

EDIT:

Short Specs List:
CPU: i5-4670K @3.8GHz
GPU: 2GB GTX 660
RAM: 8GB DDR3 @1600MHz

Attachments: 4932869.png(56Kb)


Edited by lwaters1996 - Sunday, 23.11.2014, 13:24
 
HarbingerDawnDate: Sunday, 23.11.2014, 13:02 | Message # 2
Cosmic Curator
Group: Administrators
United States
Messages: 8711
Status: Offline
1. http://en.spaceengine.org/forum/0-0-0-36
2. Does your computer meet the minimum hardware requirements to run SE? Virtual memory is not an indicator.





All forum users, please read this!
My SE mods and addons
Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM
 
lwaters1996Date: Sunday, 23.11.2014, 13:23 | Message # 3
Observer
Group: Newbies
Pirate
Messages: 5
Status: Offline
1. Bah. The forums hate me. I tried going to that link before posting and Chrome kept telling me no. :/ I have tried things in there in the past to no avail though.

2. I'd say 8GB of DDR3 1600MHz RAM, an i5-4670K @3.8GHz, and a GTX 660 with 2GB of VRAM is definitely more than the minimum. :P Sorry, I should have put that in the original post.

EDIT: I should add, while in-game, my total CPU usage never seems to go above 60% (and rarely gets that high) and my GPU usage caps out at 75% in Space Engine.


Edited by lwaters1996 - Sunday, 23.11.2014, 13:25
 
lwaters1996Date: Sunday, 23.11.2014, 13:29 | Message # 4
Observer
Group: Newbies
Pirate
Messages: 5
Status: Offline
Quote DoctorOfSpace
Did you try the fix for Nvidia drivers or update to the latest ones that fixed the previous issues? Did you set threaded optimization to off for SpaceEngine in the Nvidia control panel?


Drivers shouldn't be an issue since every one I am playing with is running the same generation GPU with the same exact drivers, but I'll look into it. As for the threaded optimization, I'll make sure to disable that.

Don't see how any of this would affect (effect?) my virtual memory usage and subsequently Space Engine closing C++ in a fashion that crashes everything but who knows! Trying now.

EDIT: "Same exact drivers" meaning the absolute latest ones from Nvidia. I'm the only one of a group of 5 people experiencing this issue.


Edited by lwaters1996 - Sunday, 23.11.2014, 13:30
 
DoctorOfSpaceDate: Sunday, 23.11.2014, 13:41 | Message # 5
Galaxy Architect
Group: Global Moderators
Pirate
Messages: 3590
Status: Offline
Accidentally hit delete on my post, meant to hit edit.

How much HDD space do you have left on your drive? If you are running low this can affect virtual memory. You can disable virtual memory writing in Advanced System settings and rely solely on RAM. Alternatively you can lower the maximum pagefile size.

I had similar issues in the past with programs freezing and crashing and disabling Virtual memory solved that.





Intel Core i7-5820K 4.2GHz 6-Core Processor
G.Skill Ripjaws V Series 32GB (4 x 8GB) DDR4-2400 Memory
EVGA GTX 980 Ti SC 6GB
 
lwaters1996Date: Sunday, 23.11.2014, 13:45 | Message # 6
Observer
Group: Newbies
Pirate
Messages: 5
Status: Offline
Quote DoctorOfSpace ()
You can disable virtual memory writing in Advanced System settings and rely solely on RAM.


You know what. That's probably it. I forgot that I set virtual memory to be tiny as fuck since I have Windows on a 256GB SSD and wanted to keep as much space as possible Space Engine is also on my SSD. It still has 190GB free (freed up so much space recently) so that's no problem haha

I'll disable virtual memory and do some more testing.
 
DoctorOfSpaceDate: Sunday, 23.11.2014, 13:51 | Message # 7
Galaxy Architect
Group: Global Moderators
Pirate
Messages: 3590
Status: Offline
Quote lwaters1996 ()
SSD


You probably don't want to use pagefile storage on an SSD to begin with. All those read/write cycles will not be good for the longevity of your drive. It is best to keep pagefile enabled if it doesn't cause problems, but you should enable it on a separate drive, preferably a standard mechanical drive since those are a well developed technology in comparison to SSDs and tend to have larger storage capacity.





Intel Core i7-5820K 4.2GHz 6-Core Processor
G.Skill Ripjaws V Series 32GB (4 x 8GB) DDR4-2400 Memory
EVGA GTX 980 Ti SC 6GB
 
HarbingerDawnDate: Sunday, 23.11.2014, 14:12 | Message # 8
Cosmic Curator
Group: Administrators
United States
Messages: 8711
Status: Offline
Quote lwaters1996 ()
I tried going to that link before posting and Chrome kept telling me no. :/ I have tried things in there in the past to no avail though.

It was a link to the forum rules...





All forum users, please read this!
My SE mods and addons
Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM
 
lwaters1996Date: Sunday, 23.11.2014, 14:23 | Message # 9
Observer
Group: Newbies
Pirate
Messages: 5
Status: Offline
Quote DoctorOfSpace ()
You probably don't want to use pagefile storage on an SSD to begin with. All those read/write cycles will not be good for the longevity of your drive. It is best to keep pagefile enabled if it doesn't cause problems, but you should enable it on a separate drive, preferably a standard mechanical drive since those are a well developed technology in comparison to SSDs.


Yeah. That's why I had kept it on 512MB. I know it beats the shit out of the SSD but I didn't have any options at the time. Now, though, I set a page file of 8GB-24GB on one of my HDDs so it'll never be a problem again. Space Engine seems to cap out at just under 6GB of virtual memory used so it's overkill but whatever. Not like that HDD space was being used anyway.

So far I haven't encountered any more issues so we'll see. Moving through the universe is infinitely more smooth now. I was going through globular clusters and stuff with zero loading, stuttering, lag, etc. Was pretty damn awesome.

Thanks for pointing out page file. I feel retarded for forgetting to check that. shakes my head at myself Hopefully all my issues will be gone! Thanks folks!

Added (23.11.2014, 13:23)
---------------------------------------------
Quote HarbingerDawn ()
It was a link to the forum rules...


Then Chrome has gone fully retarded one me. I give up. D:


Edited by lwaters1996 - Sunday, 23.11.2014, 14:28
 
Forum » SpaceEngine » Troubleshooting and Solutions » Space Engine Uses All Virtual Memory, Causes Crrashes (Space Engine uses 100% of virtual memory and causes crashing)
Page 1 of 11
Search: