Русский New site

Advanced search

[ New messages · Forum rules · Members ]
Page 1 of 11
Forum » SpaceEngine » Troubleshooting and Solutions » Problem while trying SE on 3K display
Problem while trying SE on 3K display
CesrateDate: Friday, 07.11.2014, 06:21 | Message # 1
Astronaut
Group: Users
China
Messages: 68
Status: Offline
3K display (2880*1620), 15.6 inches, Windows 8.1. The visual elements are amplified to 200%.
For SE, all elements, including fonts and menu, are amplified to 200% - but the problem is the whole windows is also amplified to 200% - which means it's actually displaying 2880*1620 in 31.2 inches. So it's completely unusable as 3/4 of the content are beyond the screen.
To solve this I have to either set SE resolution to a lower value or to cancel the amplifying in control panel.
 
SpaceEngineerDate: Friday, 07.11.2014, 14:14 | Message # 2
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4795
Status: Offline
I even don't know what this amplifying is (I think a sort of OS cheat). Of course SE can't work with it "out of the box" - its support must be implemented first. But I think it's better to implement GUI upscaling in the engine itself.




 
CesrateDate: Monday, 24.11.2014, 17:01 | Message # 3
Astronaut
Group: Users
China
Messages: 68
Status: Offline
Quote SpaceEngineer ()
I even don't know what this amplifying is (I think a sort of OS cheat).


In the display settings from control panel. For 3K/4K screen if the scale is still 100% then all the things displayed will be very very small.

Added (24.11.2014, 16:01)
---------------------------------------------
Another issue: When SE is on 2880*1620, moving/rotating camera quickly will cause the displayed scene to break, just like what happened when the vertical sync is disabled(even worse) - but vertical sync is forced on actually. Is that a hardware problem or SE is not capable with such a resolution?


Edited by Cesrate - Monday, 24.11.2014, 17:02
 
MosfetDate: Tuesday, 25.11.2014, 07:51 | Message # 4
World Builder
Group: Users
Italy
Messages: 718
Status: Offline
Quote Cesrate ()
In the display settings from control panel. For 3K/4K screen if the scale is still 100% then all the things displayed will be very very small


Windows 8.1 Display Scaling posed indeed a brand new series of problems to some of my customers and his monitors.





"Time is illusion. Lunchtime doubly so."
Douglas N. Adams
My mods
Asus x555ub: cpu i5-6200u - ram 4gb - gpu nvidia geforce 940m 2gb vram
 
MassiveEffectDate: Monday, 29.12.2014, 06:01 | Message # 5
Space Tourist
Group: Users
Canada
Messages: 32
Status: Offline
In windows 7, if you use Windows Font scaling (anything over 100%) will give scaling problems in some games/apps.
Using 125% or 150% Windows preset font size causes problems in mouse/screen scaling in SE and other programs.

Update and apparent fix:

A workaround for this 3K scaling bug (or 4k Resolution 3840x2160)
1. In the control panel under FONTS -> Change Font Size, set size to 100% (log out , log back in)
2. go back to Fonts -> Set Custom Text Size DPI to 160% or whatever works. (log out , log back in)
3. Use Space Engine!

Hope this helps others with a 3K or 4K Displays.





I7 2600k @ 4.5Ghz / 16GB 2133Mhz Ram / GTX 970 4GB / Crucial M4 SSD X 2 / Win7 64bit / 3840 x 2160 Resolution

Edited by MassiveEffect - Tuesday, 30.12.2014, 10:27
 
Forum » SpaceEngine » Troubleshooting and Solutions » Problem while trying SE on 3K display
Page 1 of 11
Search: