Русский New site

Advanced search

[ New messages · Forum rules · Members ]
Page 1 of 131231213»
Forum » SpaceEngine » Archive » Troubleshooting SpaceEngine 0.94 (FROM CATEGORY "TROUBLESHOOTING AND SOLUTIONS")
Troubleshooting SpaceEngine 0.94
SpaceEngineerDate: Tuesday, 14.06.2011, 20:04 | Message # 1
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4796
Status: Offline
Often the cause of the error can be found in the log file se.log in the root folder of the program. Open it in a text editor.

1) Weak system
Most of the letters of the inability to start SpaceEngine come from users that have built-in Intel office card, or some old GeForce 5700, or not "gaming" laptop. There is no way out but update of your system. There are no plans to make the second version of the engine for weak systems with simplified graphics, CPU texture generation, etc. It would be like to write one more engine. Once again I remind the minimum system requirements, which can be seen on the main page:

CPU 2.0 GHz
RAM 2 Gb
Video GeForce 6800, ATI 3850
vRAM 512 Mb

I stress that the special role played by videocard onboard memory (vRAM). 512 MB is the absolute minimum. The engine uses a large amount of data that must be in video memory (textures, meshes, vbo, etc). If your system meets the recommended requirements, the engine must work, because its development made on these hardware:

CPU 3.0 GHz
RAM 4 Gb
Video GeForce 9800 GTX, ATI Mobility HD 5730
vRAM 1024 Mb

You can try to start the engine with some OpenGL extensions disabed, if your hardware does not support them: frame buffer objects (FBO), half floats, float textures and 3D textures. Information about this is written at the beginning of the log (se.log), after the list of extensions:

Framebuffer objects supported
Half floats suppoted
Floating-point pixel format: GL_RGBA16F_ARB
3D textures suppoted


If somewhere says 'unsupported', hence the extension is not supported and the engine disable it itself. If is seems to be supported a float and 3D textures, but the atmosphere of planets has monstrous bottlenecks, such as the GeForce 6200 and GeForce 6600, it is best to disable them forcibly. This is done in the file config/main.cfg:

r_IgnoreFBO false // do not disable frame buffer objects
r_IgnoreHalfFloat false // do not disable half float
r_IgnoreFloatTextures true // disable float texture
r_Ignore3DTextures true // disable 3D textures


Reference:
- Atmospheres using float and 3D textures. Disabling any of them disables the atmosphere. HDR rendering mode uses a float textures, disabling them disables HDR.
- Stars, galaxies and all the distant objects in the form of points are using half floats. Disabling half floats does not disable the stars, etc., but it leads to greater consumption of memory (using float vertex buffers).
- The Milky Way and other nearby galaxies and nebulae are using FBO. HDR rendering mode is also uses the FBO. Disable it disables the 3D models of galaxies and nebulae, and disables HDR mode.

2) Obsolete drivers
This is most frequent error. The version of OpenGL is written at the beginning of the log:

OpenGL version: 3.3.0

If you have a version lower than 3.2.0 (2.1.1, etc.), upgrade the video card driver.

3) Black screen at startup, only mouse cursor visible
Resize the SpaceEngine window: drag its corner or edge by mouse, minimize and maximaize it or switch to full-screen mode and back (Ctrl-Enter). It is error in OpenGL initialization routine, and will be fixed in next release.

4) Planets are drawn incorrectly
If there is artifacts on the planets, no rings on Saturn and other ringed planets, and other strange glitches occurs, that arose after installing the update, delete the cache folder or make a "clean" installation in the different folder. This error occurs due the installation of a new version over an old version which previously was run. As a result, some shaders, models and other stuff from the old version remains in the cache, but some of them may not be compatible with the new version.

5) OUT_OF_MEMORY
Flashing of textures of planets (loading, then removing and start loading again), message OUT OF MEMORY and artifacts or even crash of the program after that. This occurs due to insufficient amount of video memory, or exceeding 2 GiB limit of sysrem memory (new bug version 0.94). Solutions:

a) Close all programs that can consume the video memory (games, video players, graphics editors, etc.). SpaceEngine is not a small flash game, the video memory is the most important resource for it. May helps disabling of Windows Aero theme - it consumes a lot of video memory.

b) Set the Windows XP compatibility mode for SpaceEngine.

c) Open se.log and look at its beginning to sure that the amount of video memory determined properly:

Total video memory: 1024 Mb
Available video memory: 981 Mb
Dynamic video memory detection disabled.


If 'Available video memory' is much smaller than the actual amount of your video memory, goto paragraph 'a'.
If there is written

Dynamic video memory detection unsupported. Value 1024 Mb from config will be used.

or

Can't determine total video memory size. Value 1024 Mb from config will be used.

it means that your driver does not support the determination of the amount of video memory. If updating the driver does not helps, specify the amount of video memory in the config file config/main.cfg:

VideoMemorySize 768 // video card onboard memory (VRAM) in megabytes
VideoMemoryMaxPercent 90 // max VRAM consumption (percents)
VideoMemoryStartupDetect true // use auto detection of VRAM size on startup, otherwise use r_vram_Size value
VideoMemoryDynamicDetect true // use auto detection of available amount of VRAM in runtime

If crashes continues after this, try to increase or decrease the parameter

VideoMemoryMaxPercent 90 // max VRAM consumption (percents)

But do not increase it to 100, since Windows uses 20-30 MiB.

d) If you have less than 512 MiB of video memory, try to disable procedural stars. In this case, you can fly in the Sun vicinity among the HIPPARCOS catalogue stars and visit their planets. Disabling is done in the Show objects menu, which is called by pressing F4. You must disable the procedural stars (Stars -> Procedural) and procedural planets (Planets -> Procedural). If you do not disable procedural planets, the procedural stars will continue to be used. Disabling of the procedural planets of catalogue stars (Planets -> Procedural on catalog stars) is not needed, as they do not affect it.

e) If you have more than 768 MiB of video memory, you may receive the message OUT OF MEMORY and crash after that. This is a result of the overflow of system memory. SpaceEngine cannot use more than 2 GiB of system memory (RAM), because it is a 32-bit application. No matter how many memory is installed on your system or your OS type (32 or 64 bit). In the current version (0.94) the memory manager does not check the RAM usage, this will be fixed in the next version. For current version use this solution. If you limit the useage of video memory, then it will be filled by data sooner than 2 GiB of RAM, and the old data will be removed properly. Set a limit of 768-1024 MB. To do this, open the main.cfg and edit the parameter VideoMemoryMaxPercent. For example, if you have 1280 MB of video memory, set the limit of 75 percent (VideoMemoryMaxPercent 75), if 2048 - Set 45% (VideoMemoryMaxPercent 45), etc.

6) Crashing near planets on the ATI cards
This occurs sometimes when generating mipmaps of textures of the landscape processed. The config main.cfg have the option which disables the creation of mipmaps:

BugMipmaps true // true - disable mipmaps

In the version 0.94 it is set to true by default. If you have a NVidia graphics card, change it to false, it will increase the quality of textures on the planets.

7) Very slow generating of a planets with a craters (Selena, Desert, etc.)
Maybe even suspending of the program or crashing of the drivers. This usually occurs on the ATI cards, and updating of drivers can help. If not, disable the generation of craters in the main.cfg:

BugCraters true // true - to disable the generation of craters





 
NeonDate: Tuesday, 14.06.2011, 20:38 | Message # 2
Explorer
Group: SE team
Australia
Messages: 205
Status: Offline
Thanks for that Vova, alot of good info in there, didn't know alot of it,
and hopefully it'll help in some of the crashes I'm having around planets.

Also having the occasional crash at the outer reaches of universe.

BTW, that planet texture bug I was having is fixed, it fixed itself
with a correct resinstall. Thanks.
 
j0KeRDate: Friday, 17.06.2011, 23:36 | Message # 3
Explorer
Group: Users
Greece
Messages: 178
Status: Offline
And what about lagging ? Is xp compatibility mode going to solve this ?
It seems that lag still exists in 0.94 after some time of usage of the program





"Novus Ordo Seclorum"

Intel Core(E6850) 2 Duo 3.00 GHz \ Geforce GTX560 1024MB \ 4GB 667(MHz) 2 Channel RAM \ Windows 7 (32bit) \ Samsung SA700D 120hz (3D)
 
SpaceEngineerDate: Saturday, 18.06.2011, 15:26 | Message # 4
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4796
Status: Offline
I don't understand. Do you mean lags when planet textures is generating, or something else?




 
miros_0571Date: Saturday, 18.06.2011, 18:26 | Message # 5
Astronaut
Group: Banned
Ukraine
Messages: 54
Status: Offline
Use LOD -3 and will no more lags and crashes




MS Windows 7 Ultimate 32-bit SP1
Intel Pentium 4 CPU 3.20GHz, 2,0GB RAM, NVIDIA GeForce GTX 260
 
NeonDate: Saturday, 18.06.2011, 19:14 | Message # 6
Explorer
Group: SE team
Australia
Messages: 205
Status: Offline
For me, it lags when planet lod is 0, and also near centre of galaxy. I reduced
lod to -3 so it's better now.
 
j0KeRDate: Saturday, 18.06.2011, 21:51 | Message # 7
Explorer
Group: Users
Greece
Messages: 178
Status: Offline
Yeah i mean generating a lot of stars in the center of the galaxy . For example i have been in 3 to 4 galaxies and then i want to watch a planet or a nebula or something and then it gets real slow .




"Novus Ordo Seclorum"

Intel Core(E6850) 2 Duo 3.00 GHz \ Geforce GTX560 1024MB \ 4GB 667(MHz) 2 Channel RAM \ Windows 7 (32bit) \ Samsung SA700D 120hz (3D)
 
DevonXDate: Sunday, 19.06.2011, 15:45 | Message # 8
Space Pilot
Group: Users
Norway
Messages: 113
Status: Offline
Well m specs are:
CPU: Intel i7 990x Hexcore 3.46Ghz
Ram: 12gb DDR3 1333hz
GPU: 2x Nvidia GeForce 485m 2gb(4gb total VRAM) SLI
etc etc
And im still getting OUT_OF_MEMORY. I have tried setting vram to 2048 not sure if SE has sli support. Close all other programs that might use vram. setting LOD to -3. It still crashes...
 
SpaceEngineerDate: Sunday, 19.06.2011, 17:05 | Message # 9
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4796
Status: Offline
DevonX, no, set VRAM to 4Gb, but set MaxPercent to 20. Don't let SE to use all 4Gb of VRAM, because there is a issue with memory manager - it don't tae into account usage of sysem RAM. SE is 32-bit application, so it cannot take more than 2Gb of RAM. Limiting usage of VRAM leads to limiting of usage of RAM, so there must be no crashes. Read section 5)e) in the first post.




 
j0KeRDate: Sunday, 19.06.2011, 20:31 | Message # 10
Explorer
Group: Users
Greece
Messages: 178
Status: Offline
So in order to solve the slow generation i have to disable the procedural stars and set my vram (1024mb) at about 75% for now right ?




"Novus Ordo Seclorum"

Intel Core(E6850) 2 Duo 3.00 GHz \ Geforce GTX560 1024MB \ 4GB 667(MHz) 2 Channel RAM \ Windows 7 (32bit) \ Samsung SA700D 120hz (3D)
 
SpaceEngineerDate: Sunday, 19.06.2011, 21:24 | Message # 11
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4796
Status: Offline
j0KeR
You must disable procedural planets to, because they are used procedural stars. Leave only "Procedural planets on catalog stars". You can disable star clusters too, because without procedural stars whey appears only as light bulbs.
Then SE do not generates stars, and you can explore procedural plantes of catalogue stars with some speedup in scene generation.





 
j0KeRDate: Monday, 20.06.2011, 02:01 | Message # 12
Explorer
Group: Users
Greece
Messages: 178
Status: Offline
Quote (SpaceEngineer)
j0KeR
You must disable procedural planets to, because they are used procedural stars. Leave only "Procedural planets on catalog stars". You can disable star clusters too, because without procedural stars whey appears only as light bulbs.
Then SE do not generates stars, and you can explore procedural plantes of catalogue stars with some speedup in scene generation.


Yeah that indeed solved pretty much everything about lag , so there is no way to have everything and free lag ?





"Novus Ordo Seclorum"

Intel Core(E6850) 2 Duo 3.00 GHz \ Geforce GTX560 1024MB \ 4GB 667(MHz) 2 Channel RAM \ Windows 7 (32bit) \ Samsung SA700D 120hz (3D)
 
SpaceEngineerDate: Monday, 20.06.2011, 10:03 | Message # 13
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4796
Status: Offline
Wait for next releases:)




 
DwardenDate: Tuesday, 05.07.2011, 20:11 | Message # 14
Astronaut
Group: SE team
Czech Republic
Messages: 63
Status: Offline
INITIALIZING ENGINE
WARNING: TBodyBatchIBO::CreateSphere(): Too many indexes (66046), 16-bit index overflow

WARNING: TMemoryManager::UpdateAvailableMemory(): Can't determine available video memory size
ERROR: MemoryManager.CheckMemory(): Can't find old resource
Saving "config/user.cfg"
Loading "config/user.cfg"
ERROR: LandNodeCache.CreateTexture(): Error disposing memory
Saving "config/user.cfg"
Loading "config/user.cfg"
ERROR: LandNodeCache.CreateMesh(): Error disposing memory
ERROR: MemoryManager.CheckMemory(): Can't find old landscape nodes
ERROR: MemoryManager.CheckMemory(): Can't find old resource

and this keeps looping ...

usage of latest AMD drivers from not helps anything too (same as any 11.x drivers)
http://developer.amd.com/tools/gDEBugger/Pages/default.aspx#download
(btw gDEBugger is neat)

tested 1GB and 2G HD5xxx and HD6xxx cards





Ideas are like ocean w/o borders! https://twitter.com/FoltynD
 
SpaceEngineerDate: Tuesday, 05.07.2011, 20:29 | Message # 15
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4796
Status: Offline
Quote
WARNING: TBodyBatchIBO::CreateSphere(): Too many indexes (66046), 16-bit index overflow


Did you change the parameters 'PlanetSphereMeshLOD' or 'PlanetCubeMeshLOD' in the main.cfg? Change it back to 5, this is the maximum value.

*





 
Forum » SpaceEngine » Archive » Troubleshooting SpaceEngine 0.94 (FROM CATEGORY "TROUBLESHOOTING AND SOLUTIONS")
Page 1 of 131231213»
Search: