Русский New site

Advanced search

[ New messages · Forum rules · Members ]
Page 1 of 11
Forum » SpaceEngine » Archive » Generating Selena type planet slows down the progam
Generating Selena type planet slows down the progam
TuskinDate: Saturday, 11.06.2011, 15:28 | Message # 1
Space Pilot
Group: Users
Canada
Messages: 94
Status: Offline
I've found that Selena type planets when generating slow the program to a dead stop, I don't know if they finally generate but I've waited 2-3 minutes and nothing really happens.

No other Planet does this.

They generate fine in the solar system browser UI

Added (11.06.2011, 18:28)
---------------------------------------------
I tried other planets now, Ice worlds do it as well. every other type loads fine.

 
SpaceEngineerDate: Saturday, 11.06.2011, 15:34 | Message # 2
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4795
Status: Offline
This looks like a crater generation bug. Go to 'main.cfg,' and find the "BugCraters" parameter and set it to 'true.' Craters will then be disabled and this problem should disappear.

I don't know why this happens. Maybe due to hardware limitations of shader code size. Surface generaror shaders (data/shaders/tg_*.glsl) are very huge, but compiles without any error in the log anyway (right?). Maybe updating of your drivers can help...

*





 
TuskinDate: Saturday, 11.06.2011, 16:59 | Message # 3
Space Pilot
Group: Users
Canada
Messages: 94
Status: Offline
setting "BugCraters" to 'true' did not help with the problem

I'll try updating my drivers

Added (11.06.2011, 19:59)
---------------------------------------------
It appears Updating my drivers helped.

Edited by Tuskin - Saturday, 11.06.2011, 15:49
 
Forum » SpaceEngine » Archive » Generating Selena type planet slows down the progam
Page 1 of 11
Search: