RUS New site

Advanced search

[ New messages · Forum rules · Members ]
Page 17 of 221«121516171819220221»
Forum » SpaceEngine » Archive » Work progress and public beta test - 0.9.7.4
Work progress and public beta test - 0.9.7.4
SpaceEngineerDate: Thursday, 16.07.2015, 17:41 | Message # 241
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4799
Status: Offline
All updated to the date:

Changes:
- Label rendering for selected object is independent of distance and bright
- Separate buffers for left and right pass in stereo modes
- Rendering in the equirectangular spherical projection
- Added quintuple star system 1SWASP J093010.78+533859.5
- Ship HUD is hiding in interstellar mode
- Planet SurfStyle can be updated in the Planet editor
- Updated palettes for titans and iceworlds
- Alien vegetation on titans with terrestrial life
- Reduced too often impact bassins on iceworlds and titans
- Random global tint of a planets into shades of brown
- Polar caps on cold selenas and iceworlds (Ganymede-like and Pluto-like thin frost deposit)

Bugfixes:
- Fixed render of orbits in the Map mode
- Fixed bug with infinite radius of black holes, neutron stars and white dwarves
- Fixed wrong camera positioning at program startup
- Fixed artefacts with black hole and ship warp effect in stereo modes
- Fixed wrong calculation of orbital period of catalog binary stars
- Fixed interstellar ships magnitude calculation
- Fixed crash on building a ship in interstellar space
- Fixed sprites rendering order in nebulae

Screenshots:

More interesting palettes on titans:


Alien lifeforms on titans (for now they used the same tiles in atlas textures as terras):



Random coloration of the landmasses (before and after):



Polar caps on selenas:

Attachments: 3944230.jpg(272Kb) · 4754804.jpg(264Kb) · 3577857.jpg(438Kb) · 8701617.jpg(270Kb) · 9279249.jpg(300Kb) · 2779398.jpg(151Kb)





 
InariusDate: Thursday, 16.07.2015, 17:48 | Message # 242
Explorer
Group: Local Moderators
France
Messages: 237
Status: Offline
Great! I hope the full release will be soon !
 
parameciumkidDate: Thursday, 16.07.2015, 19:21 | Message # 243
Explorer
Group: Users
United States
Messages: 277
Status: Offline
YAY~!
So does this mean 0.9.7.4 revision 5 is imminent, or that 0.9.7.5 is on the horizon?





Intel HD Graphics 4000 ;P
 
SalvoDate: Thursday, 16.07.2015, 19:59 | Message # 244
Star Engineer
Group: Local Moderators
Italy
Messages: 1400
Status: Offline
I knew that you would have changed a bit planets appearance after Pluto's encounter cool

Very nice new features by the way!





The universe is not required to be in perfect harmony with human ambition.

CPU: Intel Core i7 4770 GPU: ASUS Radeon R9 270 RAM: 8 GBs

(still don't know why everyone is doing this...)
 
Natester2013Date: Thursday, 16.07.2015, 22:09 | Message # 245
Space Tourist
Group: Users
United States
Messages: 26
Status: Offline
Not sure if this belongs here, but when I go inside a nebula in 0.9.7.4 (patch 3), my display driver stops working and recovers. I got a new computer (Windows 8.1) and my graphics card (or rather APU) is AMD Radeon HD 8330. Is this an issue with AMD drivers or just on my end?

EDIT: My computer is a Hewlett-Packard 2B18 (CPU 1) that is 1.5 ghz quad core.

EDIT 2: The bug is in 0.9.7.3 too.


Edited by Natester2013 - Thursday, 16.07.2015, 22:35
 
HarbingerDawnDate: Thursday, 16.07.2015, 22:44 | Message # 246
Cosmic Curator
Group: Administrators
United States
Messages: 8714
Status: Offline
I don't have that bug, so it must be just on your end, or at most an AMD thing.




All forum users, please read this!
My SE mods and addons
Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM
 
DarkenTerraDate: Friday, 17.07.2015, 11:39 | Message # 247
Astronaut
Group: Users
China
Messages: 45
Status: Offline
Quote SpaceEngineer ()
Are you sure? Try to find (or make) the same planet in 0.972 and 0.974. This atmosphere artefact is very sensitive to conditions. Make a terrain 100 meters higher and you will not see any artefacts.


I believe what I've seen in 0972 (In fact, I tried to upload the images here, but I don't know why they can not be displayed on most of the websites cry ), though I'm not sure what effects you had added when you were updating 0.973 or 0.974. But I have a proverb for you: More effects brings more bugs smile so maybe you can try to "aplly" the atmosphere artefact form 0.972 to this version, not just cover it.......

If this method still can‘t solve this problem, I have some other suggestions:

You can set the surface of the water "completely opaque" in the distance that far enough from the player's sight.(So does the deep water area) By the way, This should only be used when the player's sight is outside the atmosphere of a planet(If not, everything goes usual just like the present 0.974).

On the other hand, you can also set the atmospheric effect "completely not displayed"in the terrain areas and the surface of the water that close enough from the player's sight. (Except the skylights ) smile

Well, em, I just know that this kind of methods are very useful in developing some of computer games, and I think they might still working in Space Engine. wink

And.........if it's still not works, well..........I'm not a professional software programmer, you know cry





Who am I ?
 
SpaceEngineerDate: Saturday, 18.07.2015, 20:20 | Message # 248
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4799
Status: Offline
Banding artefact is fixed by dithering (adding a small noise, animated over rime). Open screenshots in 1:1 resolution and look carefully on the sky.

Before


After

Attachments: 4120575.jpg(80Kb) · 6435197.jpg(175Kb)





 
AerospacefagDate: Saturday, 18.07.2015, 20:24 | Message # 249
Pioneer
Group: Users
Russian Federation
Messages: 401
Status: Offline
SpaceEngineer, applause!

How does this affect work with increased exposure levels (up to 5 at least)? I want to see.

Attachments: 7279415.jpg(103Kb)


Edited by Aerospacefag - Saturday, 18.07.2015, 20:25
 
SolarisDate: Saturday, 18.07.2015, 20:46 | Message # 250
World Builder
Group: Global Moderators
France
Messages: 731
Status: Offline
This is great !! It looks splendid.
 
SolarLinerDate: Saturday, 18.07.2015, 23:05 | Message # 251
Explorer
Group: Users
France
Messages: 267
Status: Offline
Yay to film grain! (let's call it like that heh)




custom landing page to share: http://bit.ly/spaceengine
 
SpaceEngineerDate: Saturday, 18.07.2015, 23:33 | Message # 252
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4799
Status: Offline
Exposure doesn't matter, because this effect is applied after tome mapping and bloom. Milky way indeed looking much better (especially in dynamics - noise is animated, so even less noticeable):





Galaxy sprites at exposure 32:




Attachments: 9458373.jpg(92Kb) · 3674727.jpg(197Kb) · 7267466.jpg(61Kb) · 5307266.jpg(157Kb)





 
SpaceEngineerDate: Saturday, 18.07.2015, 23:42 | Message # 253
Author of Space Engine
Group: Administrators
Russian Federation
Messages: 4799
Status: Offline
More screenes (sorry jpeg compression makes noise more worse than it is in reaity):




Attachments: 0740212.jpg(79Kb) · 4851147.jpg(181Kb)





 
DeathStarDate: Sunday, 19.07.2015, 00:58 | Message # 254
Pioneer
Group: Users
Croatia
Messages: 515
Status: Offline
Fantastic job! IMO the banding effect was the worst and most noticable on elliptical galaxies. Never actually noticed it on the sky before.
 
HarbingerDawnDate: Sunday, 19.07.2015, 03:12 | Message # 255
Cosmic Curator
Group: Administrators
United States
Messages: 8714
Status: Offline
Quote SpaceEngineer ()
jpeg compression makes noise more worse than it is in reaity

Then use PNG smile





All forum users, please read this!
My SE mods and addons
Phenom II X6 1090T 3.2 GHz, 16 GB DDR3 RAM, GTX 970 3584 MB VRAM
 
Forum » SpaceEngine » Archive » Work progress and public beta test - 0.9.7.4
Page 17 of 221«121516171819220221»
Search: