RUS New site

Advanced search

[ New messages · Forum rules · Members ]
Page 1 of 212»
Forum » SpaceEngine » Mods and Addons » Stargate Universe MOD (Remeber Stargate? Yeah, those ships.)
Stargate Universe MOD
DreagarDate: Wednesday, 25.07.2012, 18:34 | Message # 1
Observer
Group: Users
United Kingdom
Messages: 18
Status: Offline
This is now V1.02

Description: Ships from that Stargate franchise. Enjoy.

Ships - SGU

  • Destiny
  • Ancient Shuttle


Installation Instructions:
1. Add this to the end of your spacecrafts.sc found in data\textures\spacecrafts\
Code

Spacecraft  "Destiny"                  
{                  
                       Class   "Starship"                  
                       Length   746.76                  
                       Mass     18000                  
                        
                       Unit                       

                       Albedo   0.0001
                       Exposure 1.0                  
                       SpecularPower  0
                       SpecularBright 0
                       Color  ( 0.5, 0.5, 0.5 )                  

                       CurSystemID "-1.-1.-1.8403.-1.114.8.8479277.9.-1"                  
                       UnivPos     (-000000000000120099D500275E7C8BA1, +00000000000001D148A427BD5A2D39D4, +000000000000049D69EFC27311F385DA)                  
                       Orientation ( -5.417085446761192e-001, -3.493687315558363e-001, 7.134681475943026e-001, -2.746935463462905e-001 )                  
                       Velocity    ( -1.224997386835513e+001, 4.861973969254873e+001, 4.444786519330229e+001 )                  
                       AngVelocity ( 0.000000000000000e+000, 0.000000000000000e+000, 0.000000000000000e+000 )                  

                       Orbit                  
                       {                  
                        Period          1.71119e-4                  
                        SemiMajorAxis   4.927139e-5                  
                        Eccentricity    0.0                  
                        Inclination     0.0                  
                        MeanAnomaly     135.27                  
                        AscendingNode   125.08                  
                        ArgOfPericen    318.14                  
                       }                  

                       Mesh    "Destiny/Destiny.sm"                  
                       MeshEulerAngles (0, 90, 270)                  

                    DiffMap "destiny.*"

                    NormMap "destiny_normal.*"

                  //SpecMap "SHW-spec.*"

                  //DetailDiffMap "Detail-noise.*"
                  //DetailDiffScale  32.0

                  DetailBumpMap "Detail-noise.*"
                  DetailBumpScale  8.0
                  DetailBumpHeight 0.3
}

Spacecraft  "Ancient Shuttle"             
{             
                  Class   "Shuttle"             
                  Length   9.8             
                  Mass     18000             
                        
                  Unit                  

                  Albedo   0.0001
                  Exposure 1.0             
                  SpecularPower  0
                  SpecularBright 0
                  Color  ( 0.5, 0.5, 0.5 )             

                  CurSystemID "-1.-1.-1.8403.-1.114.8.8479277.9.-1"             
                  UnivPos     (-000000000000120099D50A83FC93D3CF, +00000000000001D148A42B18FBEA76DB, +000000000000049D69EFB9BF8EBBF33D)             
                  Orientation ( 1.882614366738126e-001, -8.950750584625853e-001, -3.204660017251307e-001, 2.463733202236396e-001 )             
                  Velocity    ( 5.524161104332127e+001, -7.027288514575403e+001, -5.603119420294679e+000 )             
                  AngVelocity ( -6.975736996017264e-016, -2.067651046445352e-007, -7.982126339443059e-006 )             

                  Orbit             
                  {             
                   Period          1.71119e-4             
                   SemiMajorAxis   4.927139e-5             
                   Eccentricity    0.0             
                   Inclination     0.0             
                   MeanAnomaly     135.27             
                   AscendingNode   125.08             
                   ArgOfPericen    318.14             
                  }             

                  Mesh    "AncientShuttle/AncientShuttle.sm"             
                  MeshEulerAngles (0, 270, 0)             

               DiffMap "destiny.*"

               NormMap "destiny_normal.*"

             //SpecMap "SHW-spec.*"

             //DetailDiffMap "Detail-noise.*"
             //DetailDiffScale  32.0

             DetailBumpMap "Detail-noise.*"
             DetailBumpScale  8.0
             DetailBumpHeight 0.3
}              

2. Unpack this to your SpaceEngine directory.

NOTE: If anyone wants to help make better textures for this you're more than welcome to help :P. Also these ships will take a while to load, especially Destiny, and may decrease FPS by a small amount.





Changelog:


Kudos/Credits:
SpaceEngineer for the Engine's ability to host ships biggrin
dontpanic for helping here and there
Ksst for the original models

Attachments: 5761009.jpg(117Kb) · 6214396.jpg(194Kb) · 2128453.jpg(345Kb)


Edited by Dreagar - Wednesday, 25.07.2012, 23:45
 
dontpanicDate: Wednesday, 25.07.2012, 21:25 | Message # 2
Space Pilot
Group: Users
United States
Messages: 113
Status: Offline
You have a little mistake in the spacecrafts.sc entry. The mesh of the ancient shuttle is said to be located at: "AncientShuttle/AncientShuttle.sm" but actually it is at "Destiny/AncientShuttle.sm"

EDIT: Works ok, but there is a weird bug with light. The model seems transparent and when you rotate to block a light source with the model, the screen goes black.
Screens:


Attachments: 1125082.jpg(540Kb) · 5711361.jpg(578Kb)


Edited by dontpanic - Wednesday, 25.07.2012, 21:30
 
DreagarDate: Wednesday, 25.07.2012, 23:22 | Message # 3
Observer
Group: Users
United Kingdom
Messages: 18
Status: Offline
Quote (dontpanic)
You have a little mistake in the spacecrafts.sc entry. The mesh of the ancient shuttle is said to be located at: "AncientShuttle/AncientShuttle.sm" but actually it is at "Destiny/AncientShuttle.sm"


Fixed.

Quote (dontpanic)
EDIT: Works ok, but there is a weird bug with light. The model seems transparent and when you rotate to block a light source with the model, the screen goes black.


Works fine for me, it might be because you disabled auto exposure. Here's a couple of pics with pretty much every setting on.



Attachments: 8259240.jpg(192Kb) · 7660662.jpg(221Kb)
 
dontpanicDate: Thursday, 26.07.2012, 00:37 | Message # 4
Space Pilot
Group: Users
United States
Messages: 113
Status: Offline
No, auto exposure doesn't help. Still the same transparency... Could someone else please check it out? Is something wrong with the model or is it something on my end?
 
Krazy-KillaDate: Thursday, 26.07.2012, 03:59 | Message # 5
Observer
Group: Newbies
United States
Messages: 7
Status: Offline
I'm no modeller so I was hoping someone would step in and create ships from this series. I love Stargate: Universe, and when I saw this post, I immediately checked it out! Models look great, and I look forward to trying them out once I return home from the Hospital! smile
 
DreagarDate: Thursday, 26.07.2012, 07:50 | Message # 6
Observer
Group: Users
United Kingdom
Messages: 18
Status: Offline
Quote (Krazy-Killa)
I look forward to trying them out once I return home from the Hospital!


I hope you get well soon! It's nice to be appreciated, hopefully I'll release more models if this catches on.

Quote (dontpanic)
Is something wrong with the model or is it something on my end?


Did a few tests, as far as I'm aware it works perfectly for HD Radeon 5700 series. If you're using Nvidia that might be the why...
 
Destructor1701Date: Tuesday, 31.07.2012, 16:35 | Message # 7
Pioneer
Group: Users
Ireland
Messages: 531
Status: Offline
Trying it out now.

The Destiny itself is very dark in colour - even close to a star, I can't really see much more than a sillouette. I have yet to try the shuttle.

Is there anything I can edit to make it a little brighter/more reflective?

Great work, thanks for doing this!





 
DreagarDate: Thursday, 02.08.2012, 15:41 | Message # 8
Observer
Group: Users
United Kingdom
Messages: 18
Status: Offline
Quote (Destructor1701)
Great work, thanks for doing this!


Thanks!

Quote (Destructor1701)
The Destiny itself is very dark in colour - even close to a star, I can't really see much more than a sillouette.

Quote (Destructor1701)
Is there anything I can edit to make it a little brighter/more reflective?


This should be a bit better, if not just edit the "Exposure" variable.

 
Tca_11aDate: Sunday, 20.04.2014, 23:10 | Message # 9
Space Tourist
Group: Users
Portugal
Messages: 26
Status: Offline
It needs textures.
 
RockoRocksDate: Monday, 21.04.2014, 10:19 | Message # 10
World Builder
Group: Users
Belgium
Messages: 673
Status: Offline
Quote Tca_11a ()
It needs textures.

It would need updated SM meshes for 0.97.1 first...





I will be inactive on this forum for the time being. Might come back eventually

AMD AR-3305M APU w/ Radeon HD 1.90 GHz 6,00 GB RAM
 
pfjarschelDate: Friday, 24.06.2016, 21:38 | Message # 11
Space Tourist
Group: Users
Pirate
Messages: 34
Status: Offline
Any chance this will be updated? biggrin

(I'd love to help do this, if someone could point me to the stuff I need to read!)





"Rush, Where the hell are we?"
"Several billion light years from home."
 
MosfetDate: Friday, 24.06.2016, 22:34 | Message # 12
World Builder
Group: Users
Italy
Messages: 729
Status: Offline
Porting from sketchup models to collada files with Sketchup, then exporting a .obj mesh with with Blender it's not a big problem. Textures are the problem. I could try to create the meshes, but texturing it's another thing. I can't seem to find time even for my models... I should really try to solve my issues with Blender user interface...




"Time is illusion. Lunchtime doubly so."
Douglas N. Adams
My mods
Asus x555ub: cpu i5-6200u - ram 4gb - gpu nvidia geforce 940m 2gb vram
 
pfjarschelDate: Saturday, 25.06.2016, 14:08 | Message # 13
Space Tourist
Group: Users
Pirate
Messages: 34
Status: Offline
Yeah, Blender is really non-intuitive... After reading a bit through the forums, I tried my luck at doing the import/export stuff, but SE don't seem to be able to convert the obj I got to sm... As I understood it, this should be done automatically, right? Is there something I am missing?




"Rush, Where the hell are we?"
"Several billion light years from home."
 
MosfetDate: Saturday, 25.06.2016, 14:17 | Message # 14
World Builder
Group: Users
Italy
Messages: 729
Status: Offline
yes, but pay attention to console messages (console key is the tilde if I remember well, mine is not an english keyboard). obj file must be under addons\models\spacecraft, there must be a .sss file with the .cfg file name declared. it doesn't matter if it doesn't exist, SE will create it. and .mtl material file must be under addons\textures\spacecraft, same name of the .obj file.




"Time is illusion. Lunchtime doubly so."
Douglas N. Adams
My mods
Asus x555ub: cpu i5-6200u - ram 4gb - gpu nvidia geforce 940m 2gb vram
 
pfjarschelDate: Monday, 27.06.2016, 00:24 | Message # 15
Space Tourist
Group: Users
Pirate
Messages: 34
Status: Offline
UPDATE

Here is the link to the very ugly, but functional update of these ships! The next step would be the textures, I can upload the working obj models if anyone would like to take a shot at it! I honestly have no idea of where to begin, so don't expect any updates from me too soon! (I intend to try, though)

Engine effects and docking ports working! Uses pak file.

https://drive.google.com/open?id=0B7OB_dhOlv9CTEZNZmk5WkJ2TlU

---------------------------------------------
Thanks! I think I figured out what I did wrong... I'll try again later, when I finish my current voyage ^_^

Added (25.06.2016, 23:31)
---------------------------------------------
Got it to work, I had the textures at the wrong location (same as the model), but after that, I still got an error, saying it failed to load the obj, just that.

After HOURS of trying all the different possible stuff, I noticed there was a typo at the sss line that sets the cfg location, a simple and stupid "|" character in the middle of the path... Stupid me %)

Anyway, I'll finish working on the details (thruster animations, docks), try to put a temporary texture on the big one, and then I'll upload the pak!

Thanks for the help!

Added (27.06.2016, 00:24)
---------------------------------------------
It's done, all that is left is to learn how to make proper textures smile

Attachments: 2858517.jpg(358Kb) · 7090643.jpg(353Kb)





"Rush, Where the hell are we?"
"Several billion light years from home."


Edited by pfjarschel - Monday, 27.06.2016, 01:56
 
Forum » SpaceEngine » Mods and Addons » Stargate Universe MOD (Remeber Stargate? Yeah, those ships.)
Page 1 of 212»
Search: