Русский New site

Advanced search

[ New messages · Forum rules · Members ]
Page 1 of 11
Forum » SpaceEngine » General Discussions » Main.cfg - you may want to turn up your "CacheSizeLandNode"
Main.cfg - you may want to turn up your "CacheSizeLandNode"
Ex_Date: Wednesday, 04.03.2015, 02:17 | Message # 1
Observer
Group: Newbies
United States
Messages: 5
Status: Offline
Hi there. I've been lurking for a while here, and absolutely loving Space Engine.

I've tweaked a few .cfg files to try out different values for variables, and found something that I think you may like, especially if you don't have the most expensive PC available right now.

Here's why I did this, then I'll talk about what I did biggrin

I watched a video about SE and someone in the video stated that "there's no reason to turn up your LOD unless you have gigs of VRAM to devote to it". I accepted this to a point. My computer runs fairly well with LOD at 1.0, so long as I slow down my flight around the surface of a planet and let it have a little time ot build some detail for me to enjoy.

I wanted to understand which portion of my computer was causing the bottleneck, so I turned on Resource Manager, and MSI Afterburner, to monitor my CPU, Memory, and GPU.

Surprisingly, the bottleneck appeared to be the CPU, not the GPU or memory.

What does this mean? The statement in the aforementioned video was false. You do not need more than around 1gb of vram to run LOD of 1.0 However, it is true that you will find 2.0 a bit frustrating and want to turn it down again.

You see, it seems that the creation of the terrain has to be calculated, and is therefore being t hreaded through your CPU cores. It does not appear that any of them are close to being maxed out, and all four of mine were not used by SE and weren't used evenly. (that is hopefully something that will improve over releases).

Here's what I did: I went looking in all of the cfg files for something that would let me decide to start procedural generation of terrain LOD a bit sooner, or a bit farther away from the camera. That way, it could just be done by the time I flew to it, and wouldn't have to wait.

What I found was in the Config folder of SE, in the Main.cfg file:

This value is set to 10,000 by default:
Code
CacheSizeLandNode           75000    // limit on the number of terrain nodes in the memory (0 for auto, at least 4000 for LOD 0, 10000 for LOD 2)


It isn't exactly what I was looking for, but actually it may be better!

The fact is that during the procedural generation of planets, not all of your computer's "power" is being used to get more done faster. SE leaves a lot of headroom not used on the CPU side, so if you actually turn up this Land Node Memory value a bit, your CPU can be working on, and keeping more nodes in memory so that when you look around and pan on a planet, you won't see as much being drawn for you as you need it.

Your PC will of course have a limit, so experiment with:

20,000 first. If you think it looks good and your computer doesn't seem to have any problems go to
50,000 second. Rinse repeat.
100,000 third. (for me, this started to cause SE to act weird)
Turn down a bit and test again.

My final as shown above, was 75,000

Not only do I get a smoother experience while flying around near a planet, the approach to the planet will be much more beautifully drawn as I descend. If you are near the surface, and gaze across the horizon, you'll already see many mountain ranges already drawn for you. You can, at a higher rate of speed, zoom over to those mountains and only see a final LOD drawn for you, instead of having no range when you arrive, and seeing mountains raised before your eyes.

Try it and post here if you think it is a good tweak!

If SE thinks it's good enough, maybe the default will be turned up some? Worth testing...


Edited by Ex_ - Sunday, 08.03.2015, 14:54
 
Forum » SpaceEngine » General Discussions » Main.cfg - you may want to turn up your "CacheSizeLandNode"
Page 1 of 11
Search: